La blogosfera ha acogido la aparición de la versión 2.1 de WordPress con notoria agitación, frecuentes expresiones de escepticismo y reiterados consejos de prudencia. Tal como dije en mi entrada de ayer, las novedades de esta última versión no son tan esenciales como para convertir esta actualización, que puede ser muy problemática, en una tarea imprescindible.

Tras consultar varios artículos sobre el particular (los cito al final de la entrada), he decidido cambiar la postura algo ambigua que mantuve ayer, en favor de una recomendación más rotunda: conviene esperar antes de lanzarse de cabeza a la piscina. WordPress 2.1 puede crear muchas angustias a un usuario novel, y a mi modo de ver no merece la pena pasar por ellas hasta que el proceso de actualización se haya analizado a fondo por parte de los expertos. Lástima no haber sido un poco más paciente, y haberme aplicado el consejo a mí mismo.

Supongo que en los próximos días se generará una auténtica cascada de noticias sobre los problemas de la versión 2.1 y sus posibles soluciones. A los que ya señalé ayer, añado hoy otro: que la fuente RSS de mi blog corta las entradas individuales y genera código que Feed Validator no considera correcto; más vale que el agregador de Planeta Educativo lo disculpa, porque no sé cómo arreglar las líneas erróneas.

Para quienes deseen profundizar en este asunto, y tomar con suficiente conocimiento de causa una decisión bien fundada sobre la actualización, he aquí unas cuantas referencias:

Addenda del 26 de enero, a las 21,20 horas

Acabo de darme cuenta de otro problema de compatibilidad con WordPress 2.1, que afecta a los usuarios del plugin Ultimate Tag Warrior: las etiquetas tan laboriosamente añadidas a una entrada desaparecen si alguien hace un comentario en ella, o si la entrada recibe un trackback o un pingback. El caso está descrito, junto con su solución (casi siempre hay una solución, más o menos elegante), en The new WordPress UTW gotcha.

Addenda del 28 de enero, a las 00,40 horas

La actualización a WordPress 2.1 también debe contemplar otro aspecto que no he mencionado en las líneas anteriores: la compatibilidad con el tema que utiliza el blog. La Bitácora del Tigre, que hasta hace un par de días empleaba la versión 1.2.1 del tema Tarski, sufrió algunos quebrantos por ciertos leves desacuerdos entre dicha versión y la del gestor de contenidos. Más vale que la gente de Tarski ha reaccionado con suma rapidez y, apenas en cuatro días, han publicado la versión 1.2.2, plenamente compatible con la última de WordPress.

Y, claro, otra vez el Tigre a traducir todos los ítems del tema que deben aparecer en castellano, y a pelearse con las inevitables modificaciones de las plantillas. En esta última tarea me encuentro enredado ahora mismo, en uno de los ordenadores de la red, mientras en otro hago pruebas con una Ubuntu 6.10 a la que por fin he convencido para cargar los drivers de una tarjeta gráfica ATI Radeon X700 Pro.

Addenda del 30 de enero, a las 16,30 horas

Manuel Almeida publicó ayer en Mangas Verdes una completísima crónica del proceso de actualización a WordPress 2.1. A cualquiera que ande pensando en cambiar a la última versión del CMS, se la recomiendo vivamente.